Taking something that can't be done, and then doing it.

by Jiří {x2} Činčura

You are reading

ADO.NET provider 4.5.0.0 for Firebird is ready

I’m pleased to announce new version - version 4.5.0.0 - of ADO.NET provider for Firebird. This version provides improved support for Entity Framework 6 and also countless hours and builds has been spent on hunting some race conditions in “events” support.

The “events” are having still the same public interface but the internals are greatly reviewed. Three people (me, Alexander Muylaert-Gelein, Danny Van den Wouwer if you’d like to buy as a [beer|tee|ice-cream|chocolate] during upcoming conference) spent something between three and four days turning knobs over the places. But if you look at the code, changes are really small. The beauty of bug fixing.

The Entity Framework 6 support has now been split into separate EntityFramework.Firebird assembly and into new namespaces (FirebirdSql.Data.EntityFramework6), mostly to help with cases where you’re not using Code First, but EDMX. It’s because DDEX needs to load the provider as well and hence you likely have the FirebirdSql.Data.FirebirdClient in GAC the type collisions were almost inevitable. But take a note that FirebirdSql.Data.FirebirdClient versions used in project (i.e. from NuGet) and in GAC must match (sadly this is limitation because of how current Entity Framework tooling works). The example is updated as well.

You can get the bits from NuGet FirebirdSql.Data.FirebirdClient and EntityFramework.Firebird (or from firebirdsql.org).

High level overview of changes can be found in tracker.

Comments for this entry

 
comments powered by Disqus